Erro ao gerar imagens

Visualizando 4 posts - 1 até 4 (de 4 do total)
  • Autor
    Posts
  • #44092
    Heitor Tonet
    Participante

      Boa tarde professor!

      StackGan – texto para imagem. Quando chego neste parte do código:

      !python {d_raiz}code/main.py –cfg {d_raiz}code/cfg/eval_coco.yml –gpu 0

      ele mostra este resultado:

      Traceback (most recent call last): File “/content/AttnGAN/code/main.py”, line 91, in <module> cfg_from_file(args.cfg_file) File “/content/AttnGAN/code/miscc/config.py”, line 103, in cfg_from_file yaml_cfg = edict(yaml.load(f)) TypeError: load() missing 1 required positional argument: ‘Loader’

      O python até a o ok que carregou, mas quando chega na hora de visualizar as imagens, não aparece nada.

      #44099
      Gabriel Alves
      Moderador

        Olá Heitor!

        Devido a algumas incompatibilidades com versões mais recentes das bibliotecas, é necessário agora algumas pequenas mudanças no código do repositório. A maneira mais fácil de resolver é a seguinte:

        1) Alterar a primeira linha (que clona o repositório) agora deverá ser assim:

        !git clone https://github.com/davidstap/AttnGAN.git

        (ou seja, mudou de dvschultz para davidstap)

        2) A linha de código onde atualmente está assim

        !pip install torchvision==0.11.1
        !pip install pyyaml==5.4.1

        Deverá agora ficar assim:

        !pip install torch==1.13.1 torchvision==0.14.1 torchaudio==0.13.1 torchdata==0.5.1 torchtext==0.14.1
        !pip3 install “cython<3.0” wheel && pip3 install –no-build-isolation “pyyaml==5.4.1” 

        Se preferir, pode acessar o código da seção aqui.

        #44437
        Heitor Tonet
        Participante

          Obrigado, deu certo

          #44459
          Gabriel Alves
          Moderador

            Disponha!

          Visualizando 4 posts - 1 até 4 (de 4 do total)
          • Você deve fazer login para responder a este tópico.