Erro ao importar o sklearn

Home Fóruns Fórum Redes Neurais Artificiais em Python Erro ao importar o sklearn

Visualizando 10 posts - 1 até 10 (de 10 do total)
  • Autor
    Posts
  • #22471
    Golemba
    Participante

    Boa tarde, estou com um problema para dar continuidade nos estudos.

    quando passo o comando “from sklearn import datasets” ele esta me retornando

    from sklearn import datasets
    ModuleNotFoundError: No module named ‘sklearn’

     

    eu ja tentei instalar o modulo de varias formas, porem sempre retorna esse erro, estou usando o VScode, quando digito “pip list” ele me retorna “sklearn 0.0”.

    tenho uma pasta chamada “sklearn”  com varios arquivos dentro, mas parece que nao esta encontrando o local.

    Obrigado

     

    #22472

    Olá Golemba,

    Tente fazer o comando pip install sklearn –upgrade, para atualizar a biblioteca (estranho estar com a versão 0.0)

    Jones

    #22487
    Golemba
    Participante

    tento fazer isso no ubuntu, ele retorna o seguinte error, sendo no terminal ou no proprio vscode

    $ pip install sklearn –upgrade
    ERROR: Invalid requirement: ‘–upgrade’

    #22489

    Coloca dois traços –upgrade

    #22491
    Golemba
    Participante

    ele diz isso
    <div id=”gtx-trans” style=”position: absolute; left: 47px; top: 37px;”>
    <div class=”gtx-trans-icon”></div>
    </div>

    #22504
    Golemba
    Participante

    ou aparece isso

    (base) golemba@golemba-pc:~/Área de Trabalho/projetos pyth
    on$ pip install sklearl –update

    Usage:
    pip install [options] <requirement specifier> [package-index-options] …
    pip install [options] -r <requirements file> [package-index-options] …
    pip install [options] [-e] <vcs project url> …
    pip install [options] [-e] <local project path> …
    pip install [options] <archive url/path> …

    no such option: –update

    #22525

    Boa noite Golemba, você esta utilizando o anaconda/Spyder?

    Fabio

    #22526
    Golemba
    Participante

    eu utilizei o anaconda

    #22533
    Golemba
    Participante

    eu estou tendo este mesmo erro ao importar o tensorFlow e o pybrain.

    parece que ele esta tentando achar um arquivo com esse nome, em vez de buscar a biblioteca.

    #22549

    Boa noite Golemba, pelo o que eu pude perceber o sklearn não esta instalado. Mas antes, verifica se os passos abaixo foram seguidos durante a instalação do Anaconda.

    https://www.digitalocean.com/community/tutorials/how-to-install-anaconda-on-ubuntu-18-04-quickstart-pt

    Conforme demonstra o tutorial eu crie/ativei um ambiente virtual, e na sequencia realizei a instalação do Spyder com o comando

    conda install spyder

    Logo depois, instalei o pacote sklearn

    pip install sklearn
    
    

    Em seguida, digite no terminal o comando spyder e após a interface abrir tente digitar os comandos da aula novamente. Veja abaixo que após a instalação o import foi realizado com sucesso.

    Lembre-se que, todas as instalações de bibliotecas, assim como, a abertura do Spyder devem ser realizadas de dentro do ambiente virtual.

    No exemplo abaixo, o nome do ambiente virtual que eu criei tem o nome teste

    Tente seguir os passos que eu comentei, a instalação das demais bibliotecas devera ocorrer de modo similar. Caso tenha novas duvidas nos avise.

    Fabio

     

    • Esta resposta foi modificada 10 meses, 3 semanas atrás por Fábio Spak.
Visualizando 10 posts - 1 até 10 (de 10 do total)
  • Você deve fazer login para responder a este tópico.