Validação cruzada

Visualizando 4 posts - 1 até 4 (de 4 do total)
  • Autor
    Posts
  • #27287
    Leandro
    Participante

    Saudações

     

    Estou tendo problemas com a validação cruzada.  O resultados da validação estão todos sendo retornados como ‘nan’.

     In[]: resultados
    Out[]: array([nan, nan, nan, nan, nan, nan, nan, nan, nan, nan])

    Este é o warning retornado a cada teste.

    /opt/env/lib/python3.7/site-packages/sklearn/model_selection/_validation.py:687: UserWarning: Scoring failed. The score on this train-test partition for these parameters will be set to nan. Details: 
    Traceback (most recent call last):
    File "/opt/env/lib/python3.7/site-packages/sklearn/model_selection/_validation.py", line 674, in _score
    scores = scorer(estimator, X_test, y_test)
    File "/opt/env/lib/python3.7/site-packages/sklearn/metrics/_scorer.py", line 88, in __call__
    *args, **kwargs)
    File "/opt/env/lib/python3.7/site-packages/sklearn/metrics/_scorer.py", line 236, in _score
    y_pred = method_caller(estimator, "predict", X)
    File "/opt/env/lib/python3.7/site-packages/sklearn/metrics/_scorer.py", line 53, in _cached_call
    return getattr(estimator, method)(*args, **kwargs)
    File "/opt/env/lib/python3.7/site-packages/skorch/classifier.py", line 358, in predict
    return (y_proba[:, 1] > self.threshold).astype('uint8')
    IndexError: too many indices for array: array is 1-dimensional, but 2 were indexed
    
    UserWarning,

    Alguém teria ideia de qual é o problema?

    #27291
    Denny Ceccon
    Moderador

    Olá Leandro,

    Parece que as últimas versões do Skorch estão tendo alguns problemas, não sei se a biblioteca está recebendo manutenção dos desenvolvedores. Tenta instalar uma versão mais antiga.

    #29902
    Fernando Marins
    Participante

    Queridos, usei a versão 0.8.0 do Skorch e não deu esse problema menciona acima, porque na versão 0.10.0 ela acontece.

     

    Um abraço!

    #29903
    Denny Ceccon
    Moderador

    Olá Fernando,

    Não sei dizer, eu acredito que a última versão não está recebendo atualizações por isso os erros na mudança de versão persistem.

Visualizando 4 posts - 1 até 4 (de 4 do total)
  • Você deve fazer login para responder a este tópico.