Responder a: Treinamento de objetos personalizados

#31120

Olá Alex!

Esse gráfico chart.png é gerado apenas após concluir o primeiro ciclo de iterações, por isso que se o treinamento foi interrompido logo no início pode ser que esse .png não seja salvo (ah e sim, por padrão ele deve ser salvo no diretório principal mesmo).

A respeito do questionamento da base de dados, realmente é uma base relativamente grande então há suspeita disso ter acontecido devido a um problema de memória, ou seja uso excessivo dela. Recomendo reiniciar a sessão do Colab e realizar novamente o teste. Se possível, verifique nos status do Colab como está o consumo da RAM e se aparece algum alerta durante a execução.

Mesmo assim, eu não afirmaria que o problema é esse pois em nossos testes não tivemos esse problema mesmo lidando com bases desse tamanho, no entanto são bases diferentes e portanto condições diferentes. Aliás, já enfrentamos problemas relacionados à memória porém foi em etapas muito mais avançadas do treinamento.

E sobre o que você comentou do arquivo .cfg estar em outro diretório, não teria problema porém no comando usado para iniciar o treinamento você precisa colocar exatamente o caminho do arquivo correto. Sugiro fazer igual fizemos em aula até para ficar mais fácil e evitar confusão, mas se por algum motivo desejar mudar a pasta onde você coloca os arquivos relacionados ao modelo a ser treinado então certifique-se que está tudo de acordo no comando.

Enfim, a recomendação principal é conferir todos os parâmetros do comando, verifique se todos os arquivos estão nos devidos diretórios e inicie a execução novamente.

Caso o erro permaneça, vou precisar que me passe mais uma informação sobre o seu problema: isso ocorre após quanto tempo de treinamento mais ou menos? (questão de alguns segundos mesmo ou minutos?)